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Chapter 1 Overview
TreeChart is a program to enable attractive organization (or similar hierarchical) charts to be produced
with minimal fuss and effort.

All box sizing and positioning is automatic; all you need to do is to decide what boxes look like, what
text to put in them, and what to do for the rest of the day, while you're waiting for your colleagues to
catch up with you.

This Tutorial gives a step-by-step guide to a number of common operations. It aims to quickly get you
familiar with the operation and practical use of TreeChart by preparing an example organization chart.
In doing so, it gives only a taste of the options and functions available within the program.

The TreeChart User Guide is a comprehensive reference to working with TreeChart.

1.1 Assumed Audience

This Tutorial assumes its readers to be familiar with working with programs running under Microsoft
Windows. The basic, common, techniques for interacting with Windows programs are not described.
Only those topics where TreeChart's operation is in any way different from (say) Microsoft Write are
described in detail. Chapters 1 and 2 of your Windows User's Guide provide an excellent grounding in
the basic techniques required to control any Windows program.

1.2 Notation for Keys and Key Combinations
Key names appear as small capitals; for example, CTRL or SHIFT.

Simultaneous key combinations are linked by plus signs; for example, CTRL+B or CTRL+SHIFT+B. This
notation indicates that the user should hold down the CTRL key while pressing the B key, or hold down
the CTRL and SHIFT keys while pressing the B key.

A similar convention is used for actions with the mouse buttons; for example, SHIFT+double click. This
notation means that the user should hold down the  SHIFT key while double clicking the left mouse
button. TreeChart does not use the right mouse button.

Sequential key combinations are linked by commas; for example ALT,F. This notation indicates that the
user should press and release the ALT key, and then press and release the F key.

UP,  DOWN,  LEFT and  RIGHT represent the  DIRECTION keys, which are also available on the numeric
keypad if NUM LOCK is off.

When  describing  dialog  controls,  we  refer  to  choosing  buttons;  for  example,  "choose  the  Delete
button". To choose a button in a dialog, either click on the button with the mouse, or press  ALT+ the
underlined letter in the button legend.
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1.3 Getting Help
Extensive online Help is  always  available  to  you when you are working  with TreeChart.  Help is
offered on a context-sensitive basis. This means that the help offered normally depends on what you
were doing when you requested help.

Command Prompts

The first level of help offered is command prompts. Whenever you highlight a menu item or press (but
don't release) a Toolbar button, a description of the command is displayed in the Status bar prompt
field (if the Status bar is shown).

Online Help

TreeChart uses the standard Windows Help facility. Once the Help facility has been started, you are
free to browse amongst topics, search for key words or phrases, add your own annotations to topics, or
print topics. If you are unsure how to use Help, choose How to Use Help from the Help menu in either
TreeChart or Help itself, or press F1 when you are in Help.

Help menu

The TreeChart Help menu enables you to start the Help facility with an overall contents presented. This
can be useful if you are unsure what you need help on.

The Help menu also enables you to search the online Help for particular keywords.

Context-sensitive Help

Pressing F1 requests context-sensitive Help. The topic initially shown depends on what you were doing
when you pressed F1; if you press F1 while a menu command is highlighted, rather than perform the
command, help on the command is presented. If you press F1 while a dialog or message box is shown,
help on that dialog or message box is presented. When you're working in a dialog box, choosing the
Help button will also show help.

Once you have started the Help facility, you are free to browse among topics as normal.

Help mode

Pressing  SHIFT+F1 (or  clicking  the  Help  mode  button  on  the  Toolbar)  stops  normal  TreeChart
operation, and allows you to select something you'd like help on.

In this mode the cursor changes to an arrow with a question mark; just select a menu command or click
the left mouse button over a part of the TreeChart window to select the help topic. If you select a
command, rather than performing the command, help on the command is presented. If you don't have a
mouse, you are limited to selecting menu commands.
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Pressing ESC leaves this mode without presenting help.

Chapter 2 A Quick Tour
This chapter gives a step-by-step guide to a number of common operations. It aims to quickly get you
familiar with the operation and practical use of TreeChart without going into too much detail in any
area. The TreeChart User Guide describes in more detail everything we cover here.

2.1 Starting TreeChart
One way to start  TreeChart is to double-click on TREECHRT.EXE in the Windows File Manager.
Section 2.4 of the User Guide describes further ways of starting TreeChart.

For the following description to match what you see on the screen, and what happens as you work
through the tutorial,  certain program options should be set  to  default  settings.  If  you are running
TreeChart for the first time on your computer, this will not be a problem, but if TreeChart has been run
before  on your  computer,  some settings  might  be  different.  Since  this  might  be  confusing  in  the
tutorial, we suggest you reset two of the program options to the default settings (the other options are
unimportant for this tutorial):

1 From the File menu, choose Preferences

In the Preferences dialog:
2 Clear the Edit After Insert checkbox
3 Ensure that the Template File edit control is empty
4 Choose the OK button to complete the Preferences dialog

One other possible problem concerns fonts. The example chart uses a few of the standard TrueType
fonts included with Windows 3.1. If TrueType fonts are not enabled on your computer, or if for some
reason these standard fonts have been deleted, you will have to select different fonts from the ones we
suggest.

2.2 The TreeChart Window
TreeChart is a standard Windows MDI (Multiple Document Interface) program. This means that the
program allows you to work with more than one chart at a time.

Each open chart is shown in its own window. The windows of all open charts are contained within the
workspace of the TreeChart application window.

If  you're  unfamiliar  with  working  with  multiple  document  (chart)  windows within  an  application
window, chapters 1 and 2 of your Windows User's Guide provide an excellent grounding in the basic
techniques required.
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The Toolbar

The Toolbar is the row of buttons across the top of the TreeChart window. The buttons offer users with
a  mouse  quick  access  to  several  commonly  used  TreeChart  commands.  See  section  3.1.2  of  the
TreeChart User Guide for details.

The Status Bar

The Status Bar is the horizontal bar at the bottom of the TreeChart window that displays information
such as your location in the chart, descriptions of menu commands, keys that are locked and other
information specific to the active chart. See section 3.1.3 of the TreeChart User Guide for details.

Chart Windows

In a word processor,  a document window allows you to manipulate text. In a drawing program, a
document window allows you to manipulate picture elements (which might include lines, rectangles
and text).

In a TreeChart chart window, you are manipulating boxes, not lines, rectangles or text. You can insert,
delete and re-arrange boxes directly, but you can not directly select or change the text within boxes, the
style of text or boxes, or how connecting lines are routed.

These attributes of boxes are changed by means of dialog boxes, each shown as a result of choosing a
menu command or pressing a shortcut key. After making a change, TreeChart automatically:

● Re-calculates how large boxes need to be to contain the text

● Re-positions boxes

● Re-routes connecting lines

While re-calculating the chart is automatic, you have a considerable degree of control over how the re-
calculation is done.
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2.3 Preparing your first chart
This tutorial offers a step-by-step guide to producing a simple chart like this:

In case you need to refer to it, a completed version of this chart is included in the TreeChart package,
as file TUTORIAL.TCF.

Along the way, we'll introduce most of the powerful facilities to allow you to produce similar charts
quickly and easily.
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The steps involved in preparing a chart

Preparing a chart is a five step process:

Define a hierarchy of boxes
Enter the text for each box
Specify how the chart should look: individual boxes & interconnections
Specify any titles and border
Print & Save the chart

Naturally, TreeChart lets you jump back and forth between these steps so you can try out your ideas
before committing the chart to paper.

In this tutorial, we'll perform these steps in an order which introduces you to the various commands
TreeChart offers. Specifically, we'll use different techniques for inserting the boxes for the Software,
Hardware and Handbooks Teams. When you've become more familiar with TreeChart, you'll probably
do things in a different order.

Create a new chart:

When TreeChart started, it may have automatically created a new chart for you. Just in case you had to
change the program preferences (as described in section 2.1), we'll ignore that one, and create a new
one:

either From the File menu, choose New
or Press CTRL+N
or On the Toolbar, click the New button

The newly-created chart will be given a temporary name (ChartN), and a new chart window will be
opened within the TreeChart workspace. If the chart window doesn't fill the workspace, you may prefer
to maximize it, both to make full use of the TreeChart workspace, and to hide any other charts that
might already be open.
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2.3.1 Adding the first boxes

Add the first box to your blank chart window:

either With the mouse, drag from anywhere on the chart window
or From the Edit menu, choose Insert/Below
or Press ALT+DOWN

If you're unfamiliar with mouse operations, drag means: press and hold down the left mouse button;
drag the mouse pointer until the cursor changes, then release the mouse button.

You should now see the following within the Chart1 window:

Your chart  now contains  one box. The red rectangle surrounding the box is  called the  caret,  and
indicates that this is the Current Box. Many operations are performed on the Current Box. The caret
serves the same purpose as a caret in a Word Processing program: it shows you where any input will be
placed.

If you're working with a mouse, move the mouse cursor around the Chart1 window. As you pass over
the box, you'll notice the cursor changes. Mouse operations often depend on whether you're pointing at
a box or not.
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Inserting a second box

Lets insert another box. We'll insert below the Current Box.

either With the mouse, drag Down from the existing box
or From the Edit menu, choose Insert/Below
or Press ALT+DOWN

You should now see the following within the Chart1 window:

Notice that the caret has been moved to the newly-inserted box. TreeChart automatically makes the
newly added box the Current Box.

You can choose four directions when inserting a new box,  and insertion is  always relative to the
Current Box:

To Mouse From the Edit menu Keyboard

Insert Left drag Left from a box choose Insert/Left press ALT+LEFT
Insert Right drag Right from a box choose Insert/Right press ALT+RIGHT
Insert Above drag Up from a box choose Insert/Above press ALT+UP
Insert Below drag Down from a box choose Insert/Below press ALT+DOWN

If you're using a mouse, the cursor changes to indicate the direction of insertion. If you start a drag
operation, you can cancel it by moving back to where you started dragging from. The cursor changes
back to the 'Over Box' cursor. Releasing the mouse button here cancels the insertion.
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2.3.2 Moving around the chart

Changing the Current Box

Moving the caret,  and setting the Current  Box, is  much like setting the insertion point  in a word
processor:

With a mouse: click on a box
(IE move the cursor over the box, press and release the left mouse

button)

Keyboard: The DIRECTION keys step the caret around the chart
The HOME key moves the caret to the top-left box
The END key moves the caret to the bottom-right box

Note that while this is the normal use for the  DIRECTION,  HOME and  END keys, TreeChart can also
operate in Scroll-lock mode. If Scroll-lock mode is selected, the DIRECTION, HOME and END keys scroll
the chart within the window without moving the caret. Scroll-lock mode is toggled on & off with the
SCROLL LOCK key. The state of this key is indicated on the TreeChart window status bar.

2.3.3 Moving boxes around

Add a few more boxes (corresponding to one of the three teams), to form a chart like this:

TreeChart offers all the usual commands for deleting boxes, copying boxes to the Clipboard and
pasting boxes from the Clipboard. As an example, we'll create the boxes for the second Team by

copying the first Team's boxes rather than simply inserting new boxes.
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The first thing to do is select the boxes to be copied.
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Selecting boxes

Some TreeChart commands (for example, edit text) can only meaningfully operate on one box at a
time. These commands always work on the Current Box.

Other  commands  (for  example,  delete  boxes)  can  work  on  a  set  of  boxes  simultaneously.  These
commands will work on the selected boxes, or if no boxes are selected the Current Box.

Selected boxes are shown on the display by being drawn inverted; white boxes becoming black, for
instance. There are four basic methods of selecting boxes; in this tutorial, we'll just describe two.

Selecting a group of boxes by region

This can only be done with a mouse. If you press (and hold down) the left mouse button while not over
a box, then start to drag, a dotted rectangle will be drawn to indicate the selection region. Releasing the
mouse button completes the operation. All boxes entirely within the selection region will be selected. If
you  move  the  mouse  cursor  outside  of  you  chart  window  during  this  operation,  the  window
automatically scrolls.

The caret is moved to the first box in the selection region.

If you hold down  CTRL as you commence the selection, current selections are retained, and boxes
within the selection region are added to the set of selected boxes. If you do not hold down  CTRL,
current selections are cleared before selecting the boxes within the selection region.

Selecting a group of boxes by position.

Four commands let you select a group of boxes based on their position:

To Select From the Edit menu Keyboard

All boxes choose Select All press CTRL+A

All boxes at the same Level choose Select Level press CTRL+H
as the Current Box

All boxes directly below choose Select Subordinates press CTRL+I
the Current Box

The Current Box, and all choose Select Sub-Tree press CTRL+T
boxes below it

All of these commands are also available as buttons on the Toolbar.

These commands always add more selections. To remove any existing selections before selecting a
new group, you should de-select the current selections.
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To de-select all selected boxes:

either With the mouse, click on the chart
or From the Edit menu, choose Clear Selections
or Press CTRL+G

If you're using the mouse, clicking on a box will move the caret, clicking on the background will leave
the caret unchanged.

Copying boxes to the Clipboard

In your example chart, select the boxes shown here:

To copy these boxes to the clipboard:

either From the Edit menu, choose Copy
or Press CTRL+C
or On the Toolbar, click the Copy button

TreeChart also offers a Cut command, which copies the selected boxes to the Clipboard, then deletes
them. When you copy or cut boxes to the Clipboard, if the boxes you selected were connected, the
relative positions are remembered; if you copy a sub-tree, it can be pasted as a sub-tree.

TreeChart can also copy box text and a picture to the Clipboard, to allow you to Paste text or charts
into other programs, for instance, a word processor document.

Pasting the Clipboard contents into the chart

Make the top-most copied box the Current Box (as illustrated above).
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To paste the Clipboard contents to the right of the Current Box:

either From the Edit menu, choose Paste Right
or Press CTRL+R

The chart will automatically be redrawn as:

TreeChart also offers the options to paste below or to the left of the Current Box:

To From the Edit menu Keyboard

Paste Below choose Paste Below press CTRL+V
Paste Left choose Paste Left press CTRL+L
Paste Right choose Paste Right press CTRL+R

Pasting Below is regarded as the 'normal' operation; it is this command that has a Toolbar button, and
has been assigned the standard Paste shortcut key. If you Paste Below the Current Box, the pasted
boxes are inserted between the Current Box and any boxes that are currently below it.

Pasting boxes automatically moves the caret to the top-most pasted box.

As an example, we'll paste these boxes into the chart again. To paste the Clipboard content to the left of
the Current Box:

either From the Edit menu, choose Paste Left
or Press CTRL+L
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The chart will automatically be redrawn as:

TreeChart can also create boxes by Pasting text from other programs.

Changing your mind

If you add boxes to your chart (insert or paste) or remove boxes from your chart (cut or delete), you
can change your mind. The Undo command restores your chart to how it was before you added or
removed the boxes.

Undo that second Paste we've just performed:

either From the Edit menu, choose Undo Insertion
or Press CTRL+Z

The chart will again be redrawn:
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2.3.4 Adding text to boxes

Text associated with a box is stored as fields. Each field has a name. All boxes within a chart have the
same number  of  fields,  though as  we will  see  later,  whether  a  particular  field  is  displayed  for  a
particular box is up to you, as is its style (font, size, color) and the relative order and position of fields.

TreeChart defaults to defining two text fields: Name and Position. You can add, delete or rename fields
at  any time,  and you can change the defaults.  For the example chart,  we need to  add a field for
telephone numbers.

To add a text field:

1 either From the Chart menu, choose Define Fields
or Press F3

In the Define Text Fields dialog:
2 In the New Name edit control, enter Telephone
3 Choose the Add button
4 Choose the OK button to complete the Define Text Fields dialog

Adding a text field does not cause the chart to be re-drawn.

To edit the text in the top-most box:

The text within a box can be entered or changed using the Edit Text dialog:

1 either double-click on the box (this also makes it the Current Box)
(IE move the cursor over the box, press and release the left mouse

button
TWICE, quickly)

or 1 Move the caret to the box
2 either From the Edit menu, Choose Text

or Press ENTER

In the Edit Text Dialog:
2 In the Text cell for Field Name, enter Peter Johnstone
3 In the Text cell for Field Position, enter Project Manager
4 In the Text cell for Field Telephone, enter x121
5 Choose the OK button to complete the Edit Text dialog

Note: to move between cells, with a mouse, click on the cell; on the keyboard, press UP or DOWN.

The chart will automatically be redrawn to ensure the box is big enough to contain the text, but you'll
notice that the Telephone field we added isn't shown. If you add a text field, its initially hidden. In
section 2.3.6, when we start to change how boxes look, we'll see how to show and position this field.
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Now add text to all the other boxes. If you want the hidden telephone numbers to  exactly match the
example chart, you'll find them in a chart in section 2.3.6. The chart should now look something like
this:

2.3.5 Looking at different parts of your chart

By this point, its probable that not all of the chart will fit in your window. Notice that moving the caret
causes the chart to be scrolled so that the Current Box is visible.

As well as the standard technique of scrolling a chart window (scroll bars, PAGE UP, PAGE DOWN keys,
etc), TreeChart offers two further techniques that you can use to choose which parts of your chart you
can see:

● Zooming the display

● Outlining

Changing the zoom factor

If your chart doesn't fit in the window, as an alternative to scrolling you can view the chart at various
preset zoom factors. The Zoom factor affects only how your chart is shown on the screen, not how it is
printed (though printing does, however, offer the option of scaling your chart to fit on a page).

To From the View menu Keyboard

Zoom in (make boxes bigger) choose Zoom In press +
Zoom out (make boxes smaller) choose Zoom Out press -
Reset to normal zoom choose Zoom Normal press =

You can also choose a specific zoom factor, but only if the Toolbar is shown. To set a specific zoom
factor,  open the drop-down list on the Toolbar,  and select  the desired setting. Keyboard users can
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access this list:

F2 Opens the zoom list
DIRECTION keys change selection
ENTER confirm selection (closes list)

Whichever route you take to change the zoom factor, the current zoom setting (for the currently active
chart) is indicated on the Toolbar.

Outlining - viewing only parts of your chart

The Focus & Collapse commands allow you to select which portion of your chart is visible. Together,
they act as a graphical analog of the outlining facilities found in more sophisticated word processors.

Focus can be applied to the Current Box, to make it the root of the tree. Only the Current Box and all
boxes below it are then visible; all boxes above it or on different branches are hidden. Its a bit like
saying "in this 10-department organization chart, I only want to look at the Sales department for now".
Only one box can have the Focus at any time.

To Focus on the Hardware Team:

1 Move the caret to the Hardware Team Leader box
2 either From the View menu, choose Focus

or Press CTRL+F
or On the Toolbar, click the Focus button

The chart will be redrawn as shown:

Now de-select Focus to return to viewing the whole chart:

either From the View menu, choose Focus
or Press CTRL+F
or On the Toolbar, click the Focus button

Collapse, on the other hand, hides all boxes below the box being collapsed. Its a bit like saying "in this
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organization chart, I only want to look at senior management for now". Any number of boxes can be
collapsed at the same time, and you can collapse multiple boxes in one operation. You can expand
collapsed boxes individually, as a group, or all collapsed boxes.

To show only management, we collapse the Team Leader boxes:

1 Move the caret to either Team Leader box

2 Select all boxes at the Team Leader level:
either From the Edit menu, choose Select Level
or Press CTRL+H
or On the Toolbar, click the Select Level button

3 Collapse all selected boxes:
either From the View menu, choose Collapse
or Press CTRL+K
or On the Toolbar, click the Collapse button

The chart will be redrawn as shown:

Now expand all collapsed boxes to return to viewing the whole chart:

either From the View menu, choose Expand All
or Press CTRL+SHIFT+E
or On the Toolbar, click the Expand All button

Focus & Collapse can be combined to hide as much of the chart as you like.

A Summary of Outlining commands

To From the View menu Keyboard

Collapse selected boxes choose Collapse press CTRL+K
Expand selected boxes choose Expand press CTRL+E
Expand All boxes choose Expand All press CTRL+SHIFT+E
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Focus on the Current Box choose Focus press CTRL+F
Remove Focus choose Focus press CTRL+F
View the whole chart choose View All press CTRL+Q

All of these commands are also available as buttons on the Toolbar.

The Collapse and Expand commands operate on the Current Box if no boxes are selected. The View
All command removes focus and expands all collapsed boxes.

For a chart this small, the outlining facilities offered by Focus & Collapse probably aren't much help.
For  a  1000-person  organization  in  10  departments,  it  can  be  quite  useful  to  concentrate  on  one
department or one level of management at a time.

An important point to note about Focus & Collapse is that together they define the Current View of the
chart. Wherever possible, commands operate only on the Current View. So Select All means Select All
boxes  in  the  Current  View.  Also,  when  you print  your  chart,  or  copy  a  picture  to  the  Windows
Clipboard, you're printing or copying the Current View. This allows you to treat a large chart as a series
of smaller charts, for example to print each department of an organization on a separate page.

2.3.6 Changing how boxes look

Now that we've got text in the boxes, lets change how the boxes look. To do that, we call up the Edit
Layout dialog:

To edit the Layout used by the Current Box:

either SHIFT+double-click on any Box (this also makes it the Current Box)
or From the Layout menu, choose Edit
or Press SHIFT+ENTER

The Edit Layout dialog allows you to control almost every aspect of how a box looks, and how it
connects to boxes below it. There are four main parts of this dialog:

Sample Immediate visual feedback of any change you make to the
Layout

Text For each text field: whether or not it appears, it position,
alignment, font, size, color

Box Shape, size, shadow, border width & color, interior color

Connections Define  relative  positioning  of  this  box  and  boxes
immediately below it, together with style / routing of connecting lines

Changing the text style
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In our example chart, we need to change the style of all three text fields. The text controls show the
settings for Text Field 'Name'.

To change the text style for Field 'Name':

1 Choose the Font button

In the Font dialog:
2 In the Font list, select Arial
3 In the Style list, select Bold
4 In the Size list, select 16
5 Choose the OK button to complete the Font dialog

Notice that the sample now reflects the changes you just made.

To change the text style for Field 'Position':

1 In the Field list, select 'Position'

2 Choose the Font button

In the Font dialog:
3 Select Times New Roman, Regular, size 8
4 In the Color list, select Navy
5 Choose the OK button to complete the Font dialog

To change the text style for Field 'Telephone':

1 In the Field list, select 'Telephone'

2 Clear the Hide checkbox

3 In the Horizontal Alignment list, select Right

4 In the Vertical Alignment list, select Above

5 Choose the Font button

In the Font dialog:
6 Select Courier New, Regular, size 8
7 Choose the OK button to complete the Font dialog

Changing the box style

All of the changes are to the box's appearance:
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1 In the Border Width list, select 1½ pt
2 In the Shadow list, select the thickest bottom-right shadow

3 Choose the Border Color button
In the Box Border Color dialog:

4 Select the Navy color chip.
5 Choose the OK button to complete the Box Border Color dialog

6 Choose the Fill Color button
In the Box Fill Color dialog:

7 Select the Cream color chip.
8 Choose the OK button to complete the Box Fill Color dialog

9 Choose the Shadow Color button
In the Box Shadow Color dialog:

10 Select the Silver color chip.
11 Choose the OK button to complete the Box Shadow Color dialog

Changing the connections style

The only changes we need to make are to the width and color of the connecting lines:

1 In the Line Width list, select 1½ pt

2 Choose the Line Color button
In the Connections Line Color dialog:

3 Select the Teal color chip.
4 Choose the OK button to complete the Connections Line Color dialog

Now choose the OK button to complete the Edit Layout dialog.

The chart is again automatically redrawn to reflect the changes you have made:
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But you'll notice that the appearance of all the boxes has been changed. This is because you changed a
Layout rather than a box. Each box uses one of the Layouts defined for this chart. You can have any
number of Layouts in a chart. At the moment, there's only one Layout, and all boxes are using it.
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2.3.7 Creating and working with Layouts

Layouts are similar to Style Guides found in more sophisticated word processors, and can greatly assist
you in achieving a consistent appearance to your charts. Once you've defined a Layout, you can use it
as often as you like.

You can define any number of Layouts. Each must be assigned a unique name so that it can be referred
to while preparing the chart. Give a bit of thought to naming your Layouts, since well-chosen names
can make it easier for you to choose which Layout a box should use. Two possible approaches are to
name  Layouts  functionally (eg  Manager,  Assistant,  Other  Staff)  or  descriptively (eg  'blue  circle;
connect centers', 5x3 cream box).

Every box in a chart uses one of the Layouts you have defined. When you change the settings of a
Layout, it automatically affects every box using that Layout.

In the example chart, the Layout we already have is fine for the Project Manager, but we need to create
and use another Layout for Team Leaders. If you look at the finished example chart shown earlier,
you'll see that the all the manager boxes already look like the finished chart. Why are we creating a
new Layout? The Layout used by a box specifies not only how the box appears, and how the text
appears, but also how that box is connected to its immediate subordinates. Its here that the Layout used
by the Team Leaders must differ from that used by the Project Manager; the example chart calls for
staff below a Team Leader to be in a list.

General Layout management is done in the Define Layouts dialog.

To show the Define Layouts dialog:

either From the Layout menu, choose Define Layouts
or Press CTRL+D
or On the Toolbar, click the Define Layouts button

All existing Layouts are listed, with the Layout used by the Current Box selected automatically.

Renaming the existing Layout

Before creating a new Layout, lets change the name of the Layout TreeChart created for us:

1 In the New Name edit control, enter 'Project Manager'

2 Choose the Rename button

Creating a new Layout

To create and edit a new Layout for Team Leaders:

1 In the New Name edit control, enter 'Team Leaders'
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2 Choose the New button
(this adds Team Member to the Layouts list, and automatically selects it)

3 either Choose the Edit button
or double-click on Team Leader in the Layouts list

The Edit Layout dialog is shown.

You'll notice that the initial settings of this new Layout are the same as our original Layout. When you
create a new Layout, it is initially a copy of whichever Layout was selected in the Layout List in the
Define Layouts dialog.

To position staff below a Team Leader in a list, and have thinner connecting lines:

1 From the Connections Style list, select:

2 From the Connections Line Width list, select 1pt

The sample should now look exactly as we want Team Leaders to connect to their subordinates.

Now choose the OK button to  complete the  Edit  Layout  dialog,  then  choose the Close button to
complete the Define Layouts dialog.

This time, the chart is not redrawn; nothing we've done affects the boxes, since none of the boxes are
using the newly-created Layout. 

Making boxes use a different Layout

To make the Team Leader boxes use the newly-created Team Leader Layout:

1 Move the caret to either Team Leader box

2 Select all boxes at the Team Leader level:
either From the Edit menu, choose Select Level
or Press CTRL+H
or On the Toolbar, click the Select Level button

3 Show the Define Layouts dialog:
either From the Layout menu, choose Define Layouts
or Press CTRL+D
or On the Toolbar, click the Define Layouts button

In the Define Layouts dialog:
4 In the Layouts list, select Team Leader
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5 Choose the Use button
6 Choose the Close button to complete the Define Layouts dialog

Now, the chart will be re-drawn with the subordinate boxes positioned, and the connections routed as 
you selected:

If you now use the DIRECTION keys to step the caret around the boxes, you'll discover (for example)
that the "John Gillespie" box is still to the right of the "Pete Strutt" box, despite being drawn below it.

Stepping the caret with the DIRECTION keys and inserting boxes both operate in terms of the hierarchy
rather than how boxes are drawn. For example, inserting a new box below the "John Gillespie" box
will always insert a subordinate, no matter how boxes have been drawn.

Creating a third Layout for Team Members

In the example chart, junior staff are shown differently to the managers: only their names are shown,
and there's no box or shadow.
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As you might guess, a third Layout is called for. The process of defining this is identical to the new
Layout we just created, but we can speed it up slightly by selecting in advance the boxes that need to
use the new Layout:

1 Move the caret to any of the junior staff boxes

2 Select all boxes at this level:
either From the Edit menu, choose Select Level
or Press CTRL+H
or On the Toolbar, click the Select Level button

3 Show the Define Layouts dialog:
either From the Layout menu, choose Define Layouts
or Press CTRL+D
or On the Toolbar, click the Define Layouts button

In the Define Layouts dialog:
4 In the New Name edit control, enter 'Team Member'
5 Choose the New button

(this adds Team Member to the Layouts list, and automatically selects it)
6 Choose the Use button
7 either Choose the Edit button

or double-click on Team Member in the Layout list

The Edit Layout dialog is shown.

This time, we want to have the Name text field left-aligned, hide the Position and Telephone text
fields, and remove the box border and shadow.

Changing the text styles

To change the text style for Field 'Name':

1 Choose the Font button
In the Font dialog:

2 In the Size list, select 12
3 Choose the OK button to complete the Font dialog

4 In the Horizontal Alignment list, select Left

To change the text style for Field 'Position':

1 In the Field list, select 'Position'

2 Select the Hide checkbox
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To change the text style for Field 'Telephone':

1 In the Field list, select 'Telephone'

2 Select the Hide checkbox

Changing the box style

1 In the Border Width list, select (none)

2 In the Shadow list, select no shadow

3 Select the Transparent checkbox

There's no need to change the Connections style, since Team Members will not have any subordinate
boxes.

Choose the OK button to complete the Edit Layout dialog. Then choose the Close button to complete
the Define Layouts dialog.

The chart will again be automatically redrawn:
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Box size and spacing

You have complete control  over the size of an individual box, the spacing between a box and its
subordinates, and how box sizes are matched on a chart-wide basis.

You'll notice that while the default size and spacing settings look fine for the senior staff, the junior
staff are positioned a bit extravagantly. We need to push them together a bit.

There are two factors determining the size and positioning of the junior staff boxes:

● The size of the (invisible) box for the Team Member Layout

● The spacing settings of the Team Leader Layout

Both of these require you to specify distances or margins. We won't go into the details of what each of
the margins mean in this tutorial, we'll just change them.

Adjusting the box size of Team Members

1 Move the caret to any one of the Team Member boxes

2 either From the Layout menu, choose Size
or Press F8

In the Box Size dialog:
3 In the Top margin edit control, enter 0
4 In the Left margin edit control, enter 0.05"
5 In the Bottom margin edit control, enter 0
6 In the Right margin edit control, enter 0.05"
7 Choose the OK button to complete the Box Size dialog

Adjusting the spacing of Team Leaders

1 Move the caret to any one of the Team Leader boxes

2 either From the Layout menu, choose Spacing
or Press SHIFT+F8

In the Box Spacing dialog:
3 Set the Minimum Distance between this box and subordinates to 0.2"
4 Set the Minimum Vertical Distance between subordinates to 0.1"
5 Set the Offset Distance between this box and subordinates to 0.1"
6 Set the Vertical Stem Distance to 0
7 Choose the OK button to complete the Box Spacing dialog
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Matching box sizes

While the size of individual boxes is determined by the text that they contain, and Layout options like
Fonts & Box Size, TreeChart also offers a variety of options to automatically make boxes the same
size. The best option for the example chart is to have boxes using the same Layout made the same
width.

To match box widths among boxes using a Layout:

1 From the Chart menu, choose Match Box Sizes

In the Match Box Sizes dialog:
2 In the Width Rule group, select Equal Using Layouts
3 Choose the OK button to complete the Match Box Sizes dialog

The chart is again redrawn:

2.3.8 Speeding up adding boxes

Defining the initial Layout of a new box

When a new box is inserted, the Layout it initially uses is determined by the level the box is at within
the chart. You can decide which Layout is the default for each level, so that any new boxes you add can
immediately  use  Layouts  you  have  defined.  The  Default  Layout  can  be  thought  of  as  the  'most
probable' Layout to use for a box; you can always change which Layout a box uses.

We'll choose to have boxes at level 2 to initially use Layout 'Team Leader' and boxes at level 3 to
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initially use Layout 'Team Member':

1 From the Layout menu, choose Defaults

In the Default Layouts dialog:
2 In the Level 2 list, select Team Leaders
3 In the Level 3 list, select Team Members
4 Choose the OK button to complete the Default Layouts dialog

To be prompted for box text when you insert a new box

When you insert a new box, TreeChart will optionally prompt you automatically for the text to go in
the box. So far, we've had this option turned off. This allowed us to construct the hierarchy of boxes
while  ignoring  the  text.  Now  that  we've  got  most  of  the  hierarchy  in  place,  it  would  be  more
convenient if we were automatically prompted.

1 From the File menu, choose Preferences

In the Preferences dialog:
2 Select the Edit After Insert checkbox
3 Choose the OK button to complete the Preferences dialog

Inserting the Handbooks boxes

Now, if you insert new boxes at levels two or three they will initially use the Default Layouts you've
just defined. Now add the three boxes for the Handbooks Team, and enter their text.

Take care when inserting the "Pamela Evans" box. The Team Leader's  Layout causes the "Pamela
Evans" box to be drawn underneath the "Robert Allen" box, but it must be inserted to the right of the
"Robert Allen" box, since they are both subordinates of the Team Leader. Any box inserted below the
"Robert Allen" box would be a subordinate of Robert Allen, which is not what is needed here. If you
insert a box with the wrong relationship, you can undo the insertion: from the Edit menu, choose Undo
Insertion. Alternatively, press CTRL+Z.
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After you've inserted the three boxes, the chart will be redrawn like this:

2.3.9 Adding an Assistant

We've left the Project Manager's Assistant until last when preparing the first chart because that box is a
little different.

One of the big benefits  of TreeChart  is  that  it  automatically positions boxes uniformly. TreeChart
regards an Assistant as just another subordinate, but one that is marked as an exception to the normal
Layout rules.

There are a number of other ways you can mark boxes as exceptions to the rules. These can help you
illustrate, for example,  Co-Managers (dual-reporting structures), and junior staff who report directly to
a senior member of staff.

To add the new box, and mark it as an Assistant:

1 Insert a new box below the Project Manager
(note that the new box initially uses the Default Layout for level 2: Team Leader)

In the Edit Text Fields dialog: (automatically shown)
2 Enter the box text

3 either From the Edit menu, choose Mark Boxes
or Press CTRL+M
or On the Toolbar, click the Mark Boxes button

In the Mark Boxes dialog:
4 Select the Assistant checkbox
5 Choose the OK button to complete the Mark Boxes dialog
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In our chart, we created a new Layout (imaginatively called 'Assistant'). In this Layout, we:

● Hid the Position Text Field
● Set the Name Text Field font to Arial, Bold, size 10
● Chose a thin Shadow
● Chose a Border Width of 1 pt
● Chose size margins of: Top 0.05", Left 0.1", Bottom 0.05", Right 0.1"

After making these changes, and telling the new box to use the Assistant Layout, the chart looks like 
this:

2.3.10 Adding a Border and printing the chart

An important point to note is that TreeChart always prints the Current View - that is, if you have
applied Focus to any box, or collapsed any boxes, these outlining selections are applied to the printed
chart as well as the chart displayed on the screen. What you see on the screen is what will be printed.
To print the whole chart, you must view the whole chart. To print just one department or level of
management, view that department or level of management.

Preview before printing

Before actually printing, lets see what the chart will look like.

either From the File menu choose Print Preview
or On the Toolbar, click the Print Preview button
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The entire TreeChart window is replaced by a Print Preview window. This allows you to look at your
chart exactly as it would be printed. You can view one or two pages at a time, and you can zoom in by
clicking on a page. Depending on your printer settings, the chart might be shown split over a number
of pages.

Notice that a border has been added to the chart. The Border can be thought of as a large box which
frames your chart. Like a box, it has text fields, and uses a Layout. While all boxes within a chart have
the same text fields, you define totally independent text fields for the Border.

Close the Print Preview window by choosing the Close button.

Changing the Border Text

To edit the Border text:

either double-click on the chart background (IE anywhere except over a box)
or From the Chart menu, choose Border Text
or Press F7

The Edit Border Text dialog appears. This is identical to the box text dialog you saw earlier, except that
different text fields have been defined. 

TreeChart defaults to defining four Border Text Fields: Header, Footer, Title and Subtitle. You can add,
delete or rename fields at any time, and you can change the defaults. For the example chart, we simply
used the default fields.

Change the text to something more appropriate; we used:

Header: TreeChart Version 1.0
Footer: 15 July 1993
Title: Tutorial Example Chart
Subtitle: See TUTORIAL.WRI

Now choose the OK button to complete the Edit Border Text dialog.

Changing the Border Layout

To edit the Border Layout:

either SHIFT+double-click on the chart background
or From the Chart menu, choose Border Layout
or Press SHIFT+F7

Editing the Border Layout is pretty much like editing any other Layout, though a few options aren't
available.
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Changing the text styles

We need to select different fonts, and re-position some fields.

To change the text style for Field 'Header':

1 Choose the Font button
In the Font dialog:

2 Select Arial, Regular, 8, Black
3 Choose the OK button to complete the Font dialog

4 In the Horizontal Alignment list, select Left

To change the text style for Field 'Footer':

1 In the Field list, select 'Footer'

2 Choose the Font button
In the Font dialog:

3 Select Arial, Regular, 8, Black
4 Choose the OK button to complete the Font dialog

5 In the Horizontal Alignment list, select Left

To change the text style for Field 'Title':

1 In the Field list, select 'Title'

2 Choose the Font button
In the Font dialog:

3 Select Arial, Bold, 20, Black
4 Choose the OK button to complete the Font dialog

To change the text style for Field 'Subtitle':

1 In the Field list, select 'Subtitle'

2 Choose the Font button
In the Font dialog:

3 Select Arial, Bold Italic, 14, Gray
4 Choose the OK button to complete the Font dialog

5 Choose the Up button to change the field from bottom-aligned to top-aligned
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Changing the border style

We need to change the border width and color; add a drop-shadow, and adjust the distance between the
border and the Header and Footer fields.

1 In the Line Width list, select 1½ pt

2 In the Shadow list, select the thickest bottom-right shadow

3 Choose the Border Color button
In the Border Color dialog:

4 Select the Navy color chip
5 Choose the OK button to complete the Border Color dialog

6 Choose the Shadow Color button
In the Shadow Color dialog:

7 Select the Silver color chip
8 Choose the OK button to complete the Shadow Color dialog

9 Choose the Margins button
In the Border Margins dialog:

10 In the Above edit control, enter 0.05"
11 In the Below edit control, enter 0.05"
12 Choose the OK button to complete the Border Margins dialog

Now choose the OK button to complete the Edit Border Layout dialog.

Changing printer settings

A further simple step we can take before printing is select landscape printing (most appropriate for the
example we've worked through), and ask TreeChart to shrink the chart so that it all fits on one page.
TreeChart can print your chart in two different styles:

Poster where all your fonts, sizes & spacing are absolute, and your chart
will  be  printed  as  a  series  of  sheets  of  paper  that  you'll  need  to  stick
together.

Fit-to-page where all your fonts, sizes & spacing are scaled to fit on a single sheet of
paper

To select Landscape printing:

1 From the File menu, choose Print Setup

In the Print Setup dialog:
2 Select the Orientation: Landscape radio button
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3 Choose the OK button to complete the Print Setup dialog

If you don't want to print to your default printer, you should also choose the printer you would like to
print to.

To select Fit-to-Page print style:

1 From the Chart menu, choose Page Setup

In the Page Setup dialog:
2 Select the Print Style: Fit-to-Page radio button
3 Choose the OK button to complete the Page Setup dialog

Preview before printing, again

Before finally printing, lets again preview the output:

either From the File menu, choose Print Preview
or On the Toolbar, click the Print Preview button

The entire TreeChart window is again replaced by a Print Preview window. Your chart should now
look exactly like the finished version at the start of this tutorial.

Close the Print Preview window by choosing the Close button.

Print the chart

1 Ensure that the printer is turned on and connected

2 either From the File menu, choose Print
or Press CTRL+P
or On the Toolbar, click the Print button

In the Print dialog:
3 Choose the OK button to complete the Print dialog

Since printing can take a bit of time, a message box reports progress during printing, and allows you
the option of cancelling the print job.
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2.3.11 Saving the chart

So far, the example chart has been given a temporary name (Chart1). If you'd like to be able to return
to this chart after closing the TreeChart window, you'll need to save the chart to a disc file, giving it a
permanent name as you do so.

TreeChart files are stored in a compact special format, and normally would have a filename extension
of .TCF.

To save the chart:

1 From the File menu, choose Save As

In the File Save As dialog:
2 In the File Name edit control, type MYFIRST

You do not need to type the filename extension .TCF.
TreeChart automatically adds it to the filename you type.

3 Choose the OK button to complete the File Save As dialog

TreeChart can also save files in a number of other formats which can then be used by other programs.
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2.4 Postscript: Creating a Template File
Before finishing this tutorial, lets create a Template File.

A Template File is simply a chart that acts as a starting point when you create a new chart. A Template
contains:

● Definition of Text Fields
● A set of Layouts
● Definition of Default Layouts
● Other chart settings (Border, size matching rules, etc)

Normally, a Template would contain no boxes, though you can store boxes in a Template file is you
wish - these boxes would then be created automatically for you when you create a new chart.

Template files are the same format as charts, but would normally have a filename extension of .TCT to
show that they serve a different purpose.

TreeChart only recognises one Template File at a time, but you can switch Templates to any TreeChart-
format file whenever you wish.

Creating a Template File

So, having prepared our first chart, if we wanted to be able to produce charts with the same appearance
(but different text), we can simply delete all the boxes, save the chart as a Template File, then close the
chart:

Note:  Step 1 is  only needed if  some boxes were hidden by outlining; if  the View All  command is
disabled, no boxes are hidden

1 either From the View menu, choose View All
or Press CTRL+Q
or On the Toolbar, click the View All button

2 either From the Edit menu, choose Select All
or Press CTRL+A
or On the Toolbar, click the Select All button

3 either From the Edit menu, choose Delete
or Press DELETE

4 From the File menu, choose Save As
In the File Save As dialog:

5 In the Save File As Type drop-down list, select 'Template File (*.tct)'

6 In the File Name box, type MYTEMPL as a name for the file.
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You do not need to type the filename extension .TCT.
TreeChart automatically adds it to the filename you type.

7 Choose the OK button to complete the File Save As dialog

8 either From the File menu, choose Close
or Press CTRL+F4

Selecting the Template File

As you saw in section 2.1 (where we ensured that no Template File was selected before creating the
example chart), the Template File is selected from the Preferences dialog:

1 From the File menu, choose Preferences

In the Preferences dialog:
2 either In the Template File edit control, enter MYTEMPL.TCT

or 1 Choose the Browse button
In the Select Template dialog

2 Select the file MYTEMPL.TCT
3 Choose the OK button

3 Choose the OK button to complete the Preferences dialog

Creating a new chart, using the Template

Now, create a new chart:

either From the File menu, choose New
or Press CTRL+N
or On the Toolbar, click the New button

Insert  a few boxes to form a hierarchy. You'll  see that  all  the Layouts you previously created are
available, and some are used as defaults. Creating one chart is pretty simple; creating further charts in
the same style is even simpler.

To produce finished charts, you often only need to:

● Select a Template File
● Insert boxes
● Enter the box text

As well as opening TreeChart-format files, TreeChart allows you to open text-format files produced by
other programs. TreeChart then creates boxes and sets the box text automatically. Choosing the right
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Template File when you do this can enable you to prepare charts almost instantly!
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